Why did my theratube black rip of

Discussion in 'General Slingshot Discussions' started by Beginner, Sep 21, 2012.

  1. Beginner

    Beginner New Member

    25
    0
    0
    I thought theratube black would hold at least forever, but it ripped of after maybe 100 shots.<br><br><img src="http://illiweb.com/fa/i/smiles/icon_cry.gif" alt="Crying or Very sad" longdesc="11"><img src="http://illiweb.com/fa/i/smiles/icon_cry.gif" alt="Crying or Very sad" longdesc="11"><img src="http://illiweb.com/fa/i/smiles/icon_cry.gif" alt="Crying or Very sad" longdesc="11"><br><br>WHY?<br><br><img src="http://www.image-load.net/users/public/images/VuHq7PZxTG.JPG" border="0" alt=""><br><br><img src="http://www.image-load.net/users/public/images/ne7uLcgs5X.JPG" border="0" alt=""><br><br><img src="http://www.image-load.net/users/public/images/yKVuZHYnR6.JPG" border="0" alt=""><br><br><img src="http://www.image-load.net/users/public/images/ZEgEMcYnmL.PNG" border="0" alt="">
     
  2. Tysonspapa

    Tysonspapa New Member

    907
    0
    0
    is that the point where it is connected to the forks? happens usually there, the rubber "bounces" against the metal, thats were it breaks.
     

  3. Beginner

    Beginner New Member

    25
    0
    0
    <table width="90%" cellspacing="1" cellpadding="0" border="0" align="center">
    <tr><td><span class="genmed"><b>Tysonspapa wrote:</b></span></td></tr>
    <tr><td class="quote">is that the point where it is connected to the forks? happens usually there, the rubber "bounces" against the metal, thats were it breaks.</td></tr>
    </table>
    <span class="postbody"><br><br>Yes that could be possible.</span>
     
  4. Tysonspapa

    Tysonspapa New Member

    907
    0
    0
    Im Sure thats the reason. Same happened with my barnett cobra.
     
  5. softgoat

    softgoat New Member

    34
    0
    0
    Yes that is exactly where my tubes break off as well. the only thing is 100 shots seems too soon. Some people put a short piece of larger tubing on at that section to keep the tubes from flexing so much at that point.
     
  6. pelleteer

    pelleteer Middle Aged Delinquent

    546
    0
    0
    That's weird. I usually don't see that happen on my tube shooters until up near (or even over) the 1,000 shot mark (even longer on my Trumarks with the rotating prongs). I have to think this piece of tubing was damaged in some way that you didn't notice to break after only a hundred shots.
     
  7. tokSick

    tokSick Senior Member

    3,951
    1
    0
    Hi, it will give a better idea if you show a picture of the all setup. I mean slingshot with tubes on it. I use only flat bands and i cut them a bit longer than needed, then i fold a piece on the top of the fork before attaching them. I have less friction on my bands that way. Sometimes i just put a piece of rubber on the tops of the fork.